在更新PHP时如何解决错误是Joomla论坛中最常见的问题之一。对于初学者和专业人士来说,这是一项复杂的工作。但是,在正确的指导下,您可以避免大多数错误并轻松完成此工作。

在Joomla中更新PHP的入门指南

什么是PHP?

PHP 是一种流行的通用脚本语言,特别适合于Web开发。

在Joomla中,PHP是开发CMS的骨干语言。Joomla使用PHP,但未安装。安装来自托管站点,Joomla仅通过其系统使用PHP。因此,任何更新或更改都需要在适当的服务器环境中进行。

为什么需要更新PHP版本?

像任何软件一样,PHP需要不断的更新和错误修复。此外,随着Joomla的每个新版本以及新的扩展,PHP要求可能会发生变化。因此,如果您打算使站点保持最新状态或使用Joomla扩展的最新功能,则必须同时更新PHP。

在Joomla中更新PHP:逐步

您需要遵循以下3个简单步骤:

  • 第1步:备份数据
  • 第2步:检查您的Joomla网站的PHP要求
    Joomla版本
    扩展
  • 步骤3:更新方法

步骤1:备份您的网站

更新PHP是您网站的重大变化,因此在进行任何操作之前,您肯定需要备份您的数据。如果更新后出现任何错误,则可以还原到以前的备份版本。

您可以通过Cpanel或Akeeba扩展程序执行此操作。

在本教程中,我们将使用Akeeba作为备份方法,因为它是免费,易于使用且有效的。

  1. 将Akeeba备份 下载并安装到您的站点
  2. 在Akeeba控制面板中,选择立即备份
  3. 完成后,单击“ 管理备份”以下载,以便以后根据需要重新安装

在Joomla中更新PHP的入门指南

步骤2:为您的Joomla网站定义PHP要求

检查Joomla网站和PHP版本的兼容性

在撰写本文时,PHP 7.3.14是最新版本,PHP 7.0+是最受欢迎的版本。但是,对于某些较旧的Joomla版本(例如Joomla 2.5),将其更新到最新版本并不总是一个好主意,因为该版本与PHP 7.0+不兼容。

您可以检查此列表以定义Joomla网站的PHP要求。

  • 对于Joomla 4 最低版本为PHP 7.2
  • 对于Joomla 3.x-推荐版本:PHP 7.3+,最低版本:PHP 5.3.1 *
  • 对于Joomla 1.6、1.7和2.5-推荐版本:5.6
  • 对于Joomla 1.5-推荐版本:5.3

注意:

  • 对于Joomla 3.0到3.2,PHP的必需版本是5.3.1
  • 对于Joomla 3.3,最低PHP版本是5.3.10
  • 从Joomla 3.5和更高版本开始,您应严格只使用PHP 7.0+

因此,应始终考虑对PHP版本进行更新。

在Joomla中更新PHP的入门指南

检查您的扩展程序和PHP版本的兼容性

与Joomla一样,您的Joomla扩展和PHP 的兼容性也需要检查。如果与您的新PHP相比过时,则可以通过Joomla Update系统对其进行更新或安装该扩展程序的最新软件包。

询问您的托管服务提供商

这是推荐的方法,也是更新PHP版本的最简单方法。任何受信任的提供商都将免费为您提供帮助,并且您可以放心,您的网站已经得到安全保护。

通过Cpanel更新

在讨论任何托管服务提供商的控制面板时,Cpanel是一个通用术语。一些托管服务提供商(例如cloudaccess.net,Hostgator和Bluehost)允许您通过几个简单的步骤来更新PHP。

通过.htaccess文件更新

如果由于某种原因您不能使用上述两种方法更新PHP文件,则可以使用.htaccess文件完成工作。但是,我不建议使用此方法,因为除非您是这方面的专家,否则以上两种方法是更新PHP的最安全,最简单的方法。

综上所述

更新PHP应该由专业人员来处理。您的托管站点是执行此任务时最可靠的。