Joomla托管—改善老版本Joomla !网站

最近我们已经发表的研究结果,我们提供数据的使用Joomla !CMS。事实证明,超过一半的顶级网站仍在使用Joomla !1.5版本。我们已经提到过,它会带来安全风险。如果你仍然运行旧的Joomla !,在这篇文章中,我们已经决定提供一些技巧,这些技巧可以帮助提高你的网站的安全。

    • 其中许多我们分析不仅使用Joomla 1.5线的网站,但更多的是没有更新到最新版本1.5.26,仍然运行1.5.12甚至1.5.3。如果你是其中之一,你应该立即更新你的网站。
    • joomla.org关闭了访问1.5。x下载,因此对于那些尚未决定迁移到2.5或3。X。X,我们提供我们的Joomla 1.5.26封装环节。
    • 如果你还在使用Joomla的旧版本,那么也许你的网站已经受到攻击。检查你的网站已知的恶意软件,这种免费服务:Sucuri sitecheck。
    • 一个严重的安全漏洞,这是因为Joomla 1.6和更高的默认数据库前缀封闭(jos_)。因此,攻击者总是知道你的数据库中的表是如何调用的。此外,如果一个组件的安装在你的网站有一个缺陷,允许你将一个SQL注入攻击。为了避免这种情况,改变jos_前缀的任何其他。别忘了让configuration.php文件变化后,你改变了前缀太。
    • 在你的configuration.php做出了改变,它不是对文件的访问权限制多余。这可以通过将权限设置为444。
    • Joomla 1.5版本的另一个安全缺乏可能是更改默认超级管理员的用户名和ID。因此,你要做手工。创建另一个超级管理员(一定要设置用户名,不是那么简单的猜测,管理员,根等都是坏的例子;密码应该是强大的太多,我们建议使用密码生成器来创建一个强大的密码。登录与您的新的超级管理员和块/删除超级管理员与“管理员”的用户名。
    • 另一个步骤,应做保护Joomla管理员面板访问!是改变路径面板,或阻止访问使用.htaccess文件。一个积极的副作用是,攻击者将无法找到你在你的网站上的合作,管理面板没有回应从它的通常的地方。
    • 另一个标志,它可以帮助黑客了解Joomla版本上使用您的网站的meta标签“发电机”。如果攻击者可以确定在您的网站上安装的版本,它的版本,它不是一个很难找到一个现成的漏洞,简单地通过询问谷歌。出于安全原因,不促进您的网站是建立在Joomla!及其版本。
    • 在前面的步骤中我们提到了使用.htaccess文件。这个文件是Joomla标准软件包的一部分!你所要做的就是重新命名htaccess.txt为.htaccess。但请注意,你应该避免使用.htaccess文件完全如果您有访问服务器的主服务器的配置文件。使用.htaccess文件会减慢你的Apache HTTP服务器。任何指令,你可以在一个.htaccess文件最好设置在一个目录块,它将具有更好的性能,具有相同的效果。
    • Joomla!社区已经开发出先进的主人。htaccess文件,可以帮助你的网站防止未经授权的活动。但是,要确保您知道您所做的一些扩展,使用非标准的入口点可以停止工作。确保你已经仔细阅读文档。
    • 在我们的实践中,当我们恢复被黑客攻击的网站,我们经常看到,恶意软件脚本已经隐藏在长长的文件列表中,期待着它是很难找到他们。因此,它是一个必须,您跟踪在您的服务器上的无用文件,并删除它们。Joomla也是真实的!你不再使用的扩展。如果你不更新您的扩展周期,有黑客利用的安全漏洞已经成为公开,固定在最新版本的机会高。

遵循最佳实践

许多Joomla!开发人员和管理员不知道Joomla!有自己不断更新的安全检查表。你将从社区的发展找到最相关的信息,Joomla的测试和管理!网站。这个网站一定要放在你的书签。
如果你的网站已经被黑客入侵或污损,你应该做的第一件事是检查行动清单。之后,使用我们的支持服务来获得帮助;)
而不是一个结论
然而,所有提到的步骤只是临时的措施,你会得到一些额外的时间与黑客的战斗。充分利用时间,你赢了-准备你的网站迁移到新的Joomla!版本。
为你的网站在每一步的有用的链接安全上面的建议发表在我们成功的Joomla!现场检查表。此外,你会发现有信息,将帮助您使您的网站更快,提高可访问性,并吸引更多的用户。
最后,请不要低估了上述安全措施的重要性。我们已经不得不处理好几次严重的黑客攻击,由于未能遵循这些提示。